JA
  • English
Login

Unsupported Buddy FW #17611 (XL)

Menu
Relevant for:
Last updated 9 months ago
This article is also available in following languages: 
EN

What happened?

While flashing firmware to your Original Prusa XL, an error might occur, and the screen will display the following message: "Firmware/printer versions do not match! You are trying to flash FW meant for another revision of the Buddy board".

Error name: Unsupported printer version

Error code: #17611

This error is shown if you are trying to flash a firmware version that was meant for another Buddy board revision.

How to fix it?

Download the firmware and if necessary the bootloader, and transfer it to your USB drive. Make sure to unmount the drive from your operating system before physically removing it.

Insert the USB drive back into the printer and reboot the printer using the reset button directly next to the knob to initiate the flashing procedure. In case the procedure does not start, reboot the printer again by pressing the same reset button, and while the printer is booting up, press once the rotating knob.

If the issue persists, the problem might be in the USB flash drive. Find any other USB drive in your household, make sure it is formatted to FAT32, copy both firmware files and repeat the previously described procedure.

Are you still having issues? Contact our support team and let them know that you have tried to fix the issue with these instructions. We will take it from there.

Was this article helpful?

Comments

Still have questions?

Still have questions?

If you have a question about something that isn't covered here, check out our additional resources.
And if that doesn't do the trick, you can send an inquiry to [email protected] or through the button below.

Contact us